Page 1 of 1

ubuntu kernel 4.4 can not install the open source driver

PostPosted: Wed Apr 03, 2019 9:11 am
by steven
Hi All

If you can not install the open source driver please try like this :
Hi

We find that sometimes when using ubuntu kernel 4.4.0 can not install the driver , compile and install both are ok
but there is no dvb device in this case please update the kernel to 4.16 then try again

update the kernel you can do like this :
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16/linux-headers-4.16.0-041600_4.16.0-041600.201804012230_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16/linux-headers-4.16.0-041600-generic_4.16.0-041600.201804012230_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16/linux-image-4.16.0-041600-generic_4.16.0-041600.201804012230_amd64.deb
sudo dpkg -i *.deb
reboot

after reboot using
uname -a check the kernel weather is 4.16 is yes then start install like this :
#wget http://www.tbsdtv.com/download/document/linux/media_build-2019-0308.tar.bz2
# sudo rm -rf /lib/modules/`uname -r`/kernel/drivers/media/
#tar jxvf media_build-2019-0308.tar.bz2
#cd media_build
#./install.sh
#reboot

Thanks

Kind Regards

steven

Re: ubuntu kernel 4.4 can not install the open source driver

PostPosted: Sat Apr 06, 2019 10:00 pm
by crazycat
Problem caused kernel headers update after 4.4.168+ (ubuntu 4.4.0-142+ kernels)
I make temporary fix for backport patch in separate fixes branch https://github.com/tbsdtv/media_build/tree/fixes

Similar fix for old linux-dvb-drivers, if someone use it
https://bitbucket.org/CrazyCat/linux-tb ... c57ede115b

Re: ubuntu kernel 4.4 can not install the open source driver

PostPosted: Fri Apr 12, 2019 5:03 pm
by steven
hi crazycat

Thanks so much for your update

Thanks

Kind Regards

steven