Page 4 of 4

Re: LibreELEC (Krypton) v7.90.008

PostPosted: Sun Nov 20, 2016 11:52 pm
by vpeter
[quote="nanasi"][quote="buddyrm"]
Maybe it is the Version 1.3 Looks like it is waiting for some hardware readiness that never finished. :-(

I suppose that a uninitialized cpu-fuse is the cause for the phenomenon.
I remember the non-unique MAC-address trouble.

Probably not because I have such version without mac address. That's why in this case it is set to 1E:ED:19:27:1A:B2 in u-boot.

Re: LibreELEC (Krypton) v7.90.008

PostPosted: Tue Nov 22, 2016 4:28 am
by nanasi
To check the fuse value, the following uboot command can be used.
If bit1 of fuse value is zero, the security config is not initialized.
Just in case.

TBS-MatrixTV-V1.0.1.1/Profiles/MX6Q\ Linux\ Update/OS\ Firmware/files/u-boot-matrix.imx
U-Boot 2013.04 (Oct 28 2014 - 18:06:53):
[code]
U-boot> imxotp read 4
Fuse at (index: 0x4) value: 0x2
[/code]

OpenELEC-imx6.arm-6.0.0-matrix/3rdparty/bootloader/u-boot-matrix.imx
U-Boot 2015.10-rc5 (Nov 02 2015 - 19:15:41 +0100):
[code]
Matrix U-Boot> fuse read 0 4
Reading bank 0:

Word 0x00000004: 00000002
[/code]

Re: LibreELEC (Krypton) v7.90.008

PostPosted: Sun Dec 25, 2016 12:58 am
by fdt38
[quote="vpeter"]fdt38, try [url=http://vpeter.libreelec.tv/imx6-solidrun-kernel-3.14/tmp/LibreELEC-imx6.arm-7.90.008-matrix-sr-3.14-TBS5220.tar]this[/url] version.


Thanks for the link, but I missed your post so I didn't try the file (and now the link fails with Err. 404).
If you can post it again ... (sorry !)

Re: LibreELEC (Krypton) v7.90.008

PostPosted: Fri Dec 30, 2016 11:55 pm
by Cjcr
Hi vpeter,

Are you going to publish LibreElec with the latest version for Matrix? It is very welcome if you do :-D

P.S: Happy new year!

Re: LibreELEC (Krypton) v7.90.008

PostPosted: Sat Dec 31, 2016 12:09 am
by vpeter
[quote="Cjcr"]Are you going to publish LibreElec with the latest version for Matrix? It is very welcome if you do :-D
P.S: Happy new year!
Will do - I just skipped 009 and 010 because there were not much changes.

Re: LibreELEC (Krypton) v7.90.008

PostPosted: Sat Dec 31, 2016 12:23 am
by Cjcr
[quote="vpeter"][quote="Cjcr"]Are you going to publish LibreElec with the latest version for Matrix? It is very welcome if you do :-D
P.S: Happy new year!
Will do - I just skipped 009 and 010 because there were not much changes.

Oh thank you! ;)

Re: LibreELEC (Krypton) v7.90.008

PostPosted: Mon Jan 02, 2017 11:16 pm
by Ahrlad
So, my Matrix box boots about one time in five - the rest of the time it ends up with no signal to monitor and no network. I tried to read serial output and it seems it hits some kernel error when it doesn't boot - when it does boot, I can't see any errors in dmesg. I've tried reinstalling LibreElec and trying older and newer versions, with the same results.

I imagine there's some eMMC errors involved. Is there some easy way of making a LibreElec SD card, and some guide on how to get the box to boot from SD?

Re: LibreELEC (Krypton) v7.90.008

PostPosted: Sun Jan 08, 2017 4:29 am
by Cjcr
Anyone else is having problems setting up manual IP? it go always to DHCP after restart. There's no way to make it working with fixed IP. It worked fine in OpenElec 6.