Moderator Control Panel ]

TBS3102 and OSCAM

TBS3102 and OSCAM

Postby oddity » Fri Aug 15, 2014 3:02 am

What is the best reader configuration and TBS3102 switch configuration when using OSCAM?
All help greatly accepted.
Generally got some results but get card not supported error messages.
oddity
 
Posts: 18
Joined: Tue Feb 08, 2011 4:06 am

Re: TBS3102 and OSCAM

Postby oddity » Wed Aug 20, 2014 6:28 pm

details below
2014/08/20 11:22:04 12CF00 r reader1 [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
2014/08/20 11:22:04 12CF00 r reader1 [mouse] card detected
2014/08/20 11:22:07 12CF00 r reader1 [mouse] ATR: 3F FD 13 25 02 50 00 0F 33 B0 0F 69 FF 4A 50 D0 00 00 53 59 02
2014/08/20 11:22:07 12CF00 r reader1 [mouse] Init card protocol T0, FI=1, F=372, D=4, N=2
2014/08/20 11:22:07 12CF00 r reader1 [mouse] Setting baudrate to 38400 bps
2014/08/20 11:22:07 12CF00 r reader1 [mouse] Calculated work ETU is 26.05 us reader mhz = 357
2014/08/20 11:22:07 12CF00 r reader1 [mouse] ATR Fsmax is 5 MHz, clocking card to wanted user cardspeed off 3.57 MHz (specified in reader->mhz)
2014/08/20 11:22:08 12CF00 r reader1 [mouse] card system not supported
2014/08/20 11:22:08 12CF00 r reader1 [mouse] Normal mode failed, reverting to Deprecated Mode
2014/08/20 11:22:09 12CF00 r reader1 [mouse] ATR: 3F FD 13 25 02 50 00 0F 33 B0 0F 69 FF 4A 50 D0 00 00 53 59 02
2014/08/20 11:22:09 12CF00 r reader1 [mouse] Init card protocol T0, FI=1, F=372, D=4, N=2
2014/08/20 11:22:09 12CF00 r reader1 [mouse] Calculated work ETU is 104.20 us reader mhz = 357
2014/08/20 11:22:09 12CF00 r reader1 [mouse] ATR Fsmax is 5 MHz, clocking card to wanted user cardspeed off 3.57 MHz (specified in reader->mhz)
2014/08/20 11:22:13 12CF00 r reader1 [mouse] card system not supported
2014/08/20 11:22:13 12CF00 r reader1 [mouse] THIS WAS A FAILED START ATTEMPT No 1 out of max alloted of 1
2014/08/20 11:22:13 12CF00 r reader1 [mouse] card initializing error
oddity
 
Posts: 18
Joined: Tue Feb 08, 2011 4:06 am

Re: TBS3102 and OSCAM

Postby diabloss » Fri Aug 29, 2014 6:22 pm

try please if possible on another machine if possible
diabloss
 
Posts: 146
Joined: Thu Nov 22, 2012 2:51 am

Re: TBS3102 and OSCAM

Postby oddity » Sat Aug 30, 2014 11:56 pm

I only have one MOI so cannot try on another machine.
oddity
 
Posts: 18
Joined: Tue Feb 08, 2011 4:06 am

Re: TBS3102 and OSCAM

Postby diabloss » Sun Aug 31, 2014 2:15 pm

then will need more informations in order to be able to troubleshoot.

what tv provider ?
post please from oscam how did you set the reader .
diabloss
 
Posts: 146
Joined: Thu Nov 22, 2012 2:51 am

Re: TBS3102 and OSCAM

Postby oddity » Sun Aug 31, 2014 8:02 pm

Using $ky UK, configuration of OSCAM follows:-
Oscam.user file
[account]
user = tv
pwd = tv
group = 1
au = reader1
uniq =0
monlevel =4
ident = 0963:000000
caid = 0963

Oscam.server
[reader]
label = reader1
protocol = mouse
device = /dev/ttyUSB0
cacheex = 1
caid = 0963
detect = cd
ident = 0963:000000
group = 1
emmcache = 1,3,2
blockemm-unknown = 1
blockemm-g = 1
saveemm-u = 1
saveemm-s = 1
lb_weight = 101
dropbadcws = 1

TBS-3102 reader switch settings as follows
3.3v
Mouse
3.79mhz
oddity
 
Posts: 18
Joined: Tue Feb 08, 2011 4:06 am

Re: TBS3102 and OSCAM

Postby oddity » Mon Sep 01, 2014 12:24 am

Managed to try on a windows compile of Oscam, still getting the same issue with the TBS3102 reader.
Tried a friends Omnikey 3131 and it worked using the following reader config
[reader]
label = 1
description = pcsc
protocol = pcsc
device = 0
services = sky
cacheex = 1
caid = 0963
detect = cd
mhz = 600
cardmhz = 600
ident = 0963:000000
group = 1
emmcache = 1,3,2
blockemm-unknown = 1
blockemm-g = 1
saveemm-u = 1
saveemm-s = 1
lb_weight = 101
dropbadcws = 1

Cannot try on the MOI as no driver for Omnikey.
Hope this helps
oddity
 
Posts: 18
Joined: Tue Feb 08, 2011 4:06 am

Re: TBS3102 and OSCAM

Postby diabloss » Mon Sep 01, 2014 2:10 am

These are my configs, i hope it helps.


oscam.conf
[global]
usrfile = /var/log/oscamuser.log
logfile = stdout;/var/log/oscam.log
cachedelay = 120
nice = -1
maxlogsize = 100
preferlocalcards = 1
saveinithistory = 1


[newcamd]
port = xx000@0963:000000
key = 0102030405060708091011121314
keepalive = 1

[webif]
httpport = 888
httpuser = ******
httppwd = ******
httprefresh = 3
httpallowed = 127.0.0.1,192.168.0.1-192.168.1.200


oscam.server

[reader]
label = $kyuk
protocol = mouse
device = /dev/ttyUSB0
caid = 0963
ecmwhitelist = 0963:3E,42,44,45,47,4E,53,54,61,62,68,69,6A,6B,6D, 6F,71,72,73,77,78,79,7A,7C,7D,7E,80,8B
detect = cd
#mhz = 357
#cardmhz = 357
ident = 0963:000000
group = 1
emmcache = 1,3,2
blockemm-unknown = 1
blockemm-g = 1
saveemm-u = 1
saveemm-s = 1
dropbadcws = 1


oscam.user

[account]
user = *******
pwd = *******
group = 1
monlevel = 4
au = $kyuk
keepalive = 1
diabloss
 
Posts: 146
Joined: Thu Nov 22, 2012 2:51 am

Re: TBS3102 and OSCAM

Postby oddity » Tue Sep 02, 2014 1:18 am

Thanks, just tried your config but, I'm getting the same result with exactly the same error message.
oddity
 
Posts: 18
Joined: Tue Feb 08, 2011 4:06 am

Re: TBS3102 and OSCAM

Postby oddity » Tue Sep 02, 2014 3:33 am

Ok, got it working but, cannot explain why it works.

On the TBS3102 changed the switch over to Phoenix and it works perfectly.
oddity
 
Posts: 18
Joined: Tue Feb 08, 2011 4:06 am

Next

Return to MOI+

Who is online

Users browsing this forum: No registered users and 2 guests