Moderator Control Panel ]

No frontend found after installing drivers

No frontend found after installing drivers

Postby lucas » Mon Oct 28, 2019 9:03 pm

Hi,
I've tried installing the TBS 6205 on both the latest and previous versions of ubuntu but I'm having no success having the OS recognising the front ends.

I've tried the installation instructions provided on the GitHub Wiki but having no success - get the feeling I may be missing something?

I've attached the ouput of uname and lspci below (dmesg was sizeable so couldn't post but can grab snippets on request)

Any help would be great!

Thanks,

uname -a
Code: Select all
5.0.0-32-generic #34~18.04.2-Ubuntu SMP Thu Oct 10 10:36:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


lspci -vvnn
Code: Select all
03:00.0 Multimedia controller [0480]: TBS Technologies DVB-S2 4 Tuner PCIe Card [544d:6178]
   Subsystem: TBS Technologies (wrong ID) TBS6205 DVB-T2/T/C Quad TV Tuner PCIe Card [6205:0001]
   Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Interrupt: pin A routed to IRQ 255
   Region 0: Memory at b0000000 (32-bit, non-prefetchable) [disabled] [size=256K]
   Capabilities: [50] Power Management version 3
      Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
   Capabilities: [70] MSI: Enable- Count=1/1 Maskable- 64bit+
      Address: 0000000000000000  Data: 0000
   Capabilities: [90] Express (v1) Endpoint, MSI 00
      DevCap:   MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
         ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 0.000W
      DevCtl:   Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
         RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
         MaxPayload 128 bytes, MaxReadReq 1024 bytes
      DevSta:   CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
      LnkCap:   Port #0, Speed 2.5GT/s, Width x1, ASPM L0s, Exit Latency L0s unlimited, L1 <1us
         ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
      LnkCtl:   ASPM Disabled; RCB 64 bytes Disabled- CommClk+
         ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
      LnkSta:   Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
   Capabilities: [100 v1] Device Serial Number 00-00-00-00-00-00-00-00
lucas
 
Posts: 2
Joined: Thu Oct 24, 2019 3:13 am

Re: No frontend found after installing drivers

Postby xiaocao » Tue Oct 29, 2019 9:27 am

hi ,
please tell the issue log when install the driver for TBS card , flowing the steps .
Downloading and building

git clone https://github.com/tbsdtv/media_build.git
git clone --depth=1 https://github.com/tbsdtv/linux_media.git -b latest ./media
cd media_build
make dir DIR=../media
make allyesconfig
make -j4
sudo make install
sudo reboot
Firmware

wget http://www.tbsdtv.com/download/document ... .0.tar.bz2
sudo tar jxvf tbs-tuner-firmwares_v1.0.tar.bz2 -C /lib/firmware/

best regards!
xiaocao
 
Posts: 71
Joined: Tue Jun 25, 2013 5:48 pm

Re: No frontend found after installing drivers

Postby lucas » Tue Oct 29, 2019 3:25 pm

Few errors cropped up:
- make dir DIR=../media
Code: Select all
make -C linux/ dir DIR="../../media"
make[1]: Entering directory '/home/grandfalls/tbs/media_build/linux'
rm -rf drivers include sound mm .patches_applied .linked_dir .git_log.md5 git_log kernel_version.h
../../media does not contain kernel sources
/bin/sh: 1: exit: Illegal number: -1
Makefile:122: recipe for target 'dir' failed


I did notice with that build though that the media folder didn't exist but 'linux_media' did so I tried 'make dir DIR=../linux_media' which worked.

-make allyesconfig
I get a few warnings, one about not having the full kernel sources installed and the following, but it does seem to succeed:
Code: Select all
VIDEO_IPU3_CIO2: Requires at least kernel 9.255.255
VIDEO_OMAP3: Requires at least kernel 9.255.255
VIDEO_DW9714: Requires at least kernel 9.255.255
VIDEO_IPU3_IMGU: Requires at least kernel 9.255.255


The rest seems to complete fine with no warnings or errors but the result is the same
lucas
 
Posts: 2
Joined: Thu Oct 24, 2019 3:13 am

Re: No frontend found after installing drivers

Postby xiaocao » Thu Oct 31, 2019 11:58 am

hi ,

the erros is " ../../media does not contain kernel sources "

do you download the full media source using command line " git clone --depth=1 https://github.com/tbsdtv/linux_media.git -b latest ./media " ?

you can add skype jack_2431. i will help you .

best regards!
xiaocao
 
Posts: 71
Joined: Tue Jun 25, 2013 5:48 pm


Return to DVB-T2/T/C Quad TV Tuner PCIe Card TBS6205

Who is online

Users browsing this forum: No registered users and 1 guest