Page 1 of 1

TBS2600 SDI Encoder and FFMPEG

PostPosted: Fri Jul 01, 2016 3:12 am
by Jeremy6158
I've been trying to get the TBS2600 to work with FFMPEG but I'm having some trouble. Currently, we use FFMPEG to take the RTSP stream from some Axis cameras and dump it to an MP4 file on a schedule. When I try to do this with the TBS2600 that is bringing in our churches HD SDI feed, I can get it to work but get a lot of errors and get unstable video feed. It works with VLC with the following URL rtsp://192.168.1.10:554/sdi

When I try that in my FFMPEG script I get the following errors:
[rtsp @ 0x7f8fe2800800] Interleaved RTP mode is not supported yet.
And
[h264 @ 0x7fa1c3000000] unknown SEI type 229
[rtsp @ 0x7fa1c2000000] Error parsing AU headers
Last message repeated 85 times


I've looked at debug info for both the TBS2600 and the Axis camera and it looks like the main difference is that the Axis has "Packetization-mode=1" and the TBS2600 has "Packetization-mode=2" in the SDP info. I've tried the HTTP stream and the unicode stream and they generate the same errors. Can you anyone shed some light on this or tell me of a workaround?

The FFMPEG scripts I've tried to run are:

ffmpeg -loglevel debug -t 60 -i rtsp://192.168.1.10:554/sdi -c:v copy -c:a copy test2.mp4

I've tried several other working variations (worked on Axis at least) with no luck.

Re: TBS2600 SDI Encoder and FFMPEG

PostPosted: Fri Jul 01, 2016 9:52 am
by echomay
Hi, Please change "RTSP TCP" option to udp,and try change Packege Type and check again.
CatchCE9C(07-01-09-42-09).jpg
CatchCE9C(07-01-09-42-09).jpg (3.83 KiB) Viewed 3368 times
Catch(07-01-09-42-09).jpg

Re: TBS2600 SDI Encoder and FFMPEG

PostPosted: Fri Jul 01, 2016 11:50 pm
by Jeremy6158
Thanks for the input. I've tried both the "A" and "B" settings as well as TCP and UDP and get the same issues. This is what I'm getting. I also get a lot of "Error parsing AU headers" which I can't find much about online but I'm guessing it has to do with the "Interleaved RTP mode is not supported yet" error. Thanks for your help.

Screen Shot 2016-07-01 at 10.48.32 AM.png

Re: TBS2600 SDI Encoder and FFMPEG

PostPosted: Wed Jul 20, 2016 10:10 pm
by Jeremy6158
I never got this working and I'm returning the encoder.