Moderator Control Panel ]

loosing drivers after restart

loosing drivers after restart

Postby e4glenight » Thu Dec 30, 2021 2:25 am

Hello,

I have one TBS6209 in a Ubuntu server. I use closed driver. When I install it, i can see it on TvHeadEnd. but if my machine restart or loose power, i loose drivers and i have to reinstall it for making this working...

i follow the readme file :

# wget http://www.tbsdtv.com/download/document ... 25.tar.bz2
# sudo rm -rf /lib/modules/`uname -r`/kernel/drivers/media/
# tar jxvf media_build-2021-08-25.tar.bz2
# cd media_build
#./install.sh
# reboot [/code]

After reboot, i have TBS6209 visible on TvHeadEnd
Here what i get in uname dmesg and lspci

tbs@tbs:~$ uname -a
Linux tbs 5.11.0-43-generic #47~20.04.2-Ubuntu SMP Mon Dec 13 11:06:56 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
dmesg and lspci are in pdf (can't post here, too many characters and i can't attach txt files)
lspci.pdf
lspci
(54.67 KiB) Downloaded 38 times

dmesg.pdf
(84.93 KiB) Downloaded 41 times


and right now, i can use TVHeadEnd for watching TV. but if i restart or my server loosing power, i have to reinstall drivers...
Tell me if you want some add information :)

Thanks for help,

Stephane
e4glenight
 
Posts: 2
Joined: Tue Dec 28, 2021 10:00 pm

Re: loosing drivers after restart

Postby steven » Thu Dec 30, 2021 9:46 am

Hi Sir

Please check after reboot the kernel whether updated if you are using ubuntu please disable the kernel auto update with this:
#apt-mark hold linux-image-generic linux-headers-generic

thanks

kind Regards

steven
steven
 
Posts: 2219
Joined: Fri Aug 06, 2010 3:23 pm

Re: loosing drivers after restart

Postby e4glenight » Sun Jan 02, 2022 8:05 pm

hello !

Its works :)

Thanks for help,

Stéphane
e4glenight
 
Posts: 2
Joined: Tue Dec 28, 2021 10:00 pm


Return to TV Signal Cable Connection and Mode Selection

Who is online

Users browsing this forum: No registered users and 1 guest