Moderator Control Panel ]

Blue screen with APC index mismatch error

Re: Blue screen with APC index mismatch error

Postby AndersM » Sat Jun 25, 2011 10:44 pm

Hi all !

Yes i get BSOD on my W7 32bit machine but not on my W7 X64 machine different hardware though.....both Intel chipset and processor........


Regards Anders.
AndersM
 
Posts: 4
Joined: Thu Jun 16, 2011 4:55 am

Re: Blue screen with APC index mismatch error

Postby satelay » Sun Jun 26, 2011 1:52 am

Hi Steven, I am now on vacation and do not have access to either of the two machines that had problems with this card. So I am afraid I can't try your hotfix until the end of August and you will need to work with others who are having the same problem. I am surprised though, it was missed that the problem shows up under both 32 and 64 bit versions of W7 which I had clearly indicated before. Just to wrap up, the following points are the facts that I have gathered so far and may be useful in isolating the problem.

1. Problem seems to be specific to some Gigabyte MBs as reported in previous posts. Examples are: GIGABYTE GA-880GMA-UD2H and GA-MA785GM-US2H
2. Problem seems to be specific to W7 and shows up under both 32 and 64 bit versions
3. Problem is not processor dependent and shows up with both AMD and Intel processors
4. Problem seems to be specific to the TBS 8921 card/driver because TBS 6981 runs in the same machine without any problems.
5. Another thing worth mentioning is that both of my machines which had this problem are built inside an Antec fusion HTPC box which has an LCD screen, an IR remote and run the IMON manager software and related drivers. This may be causing some conflict.

I hope this is helpful. Good luck isolating the problem.
satelay
 
Posts: 11
Joined: Thu Jun 02, 2011 3:22 pm

Re: Blue screen with APC index mismatch error

Postby philerup » Sun Jun 26, 2011 6:42 am

I also am having BSOD's related to this card. My board is a gigabyte GA-790XTA-UD4 and it is running Win7 ultimate x64

The microsoft application verifier reports the Driver_x64-test-noir.rar driver driver as defective. I also ran the verifier over the release driver and it reported it as defective as well. Before i ran this test I verified my system files with sfc.exe. Here is the bugcheck analysis from windbg.

0: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

DRIVER_VERIFIER_IOMANAGER_VIOLATION (c9)
The IO manager has caught a misbehaving driver.
Arguments:
Arg1: 000000000000023b, The caller has changed the status field of an IRP it does not understand.
Arg2: fffff88005f36710, The address in the driver's code where the error was detected.
Arg3: fffff9800134ecf0, IRP address.
Arg4: 0000000000000000

Debugging Details:
------------------


BUGCHECK_STR: 0xc9_23b

DRIVER_VERIFIER_IO_VIOLATION_TYPE: 23b

FAULTING_IP:
HIDCLASS!HidpMajorHandler+0
fffff880`05f36710 48895c2410 mov qword ptr [rsp+10h],rbx

FOLLOWUP_IP:
HIDCLASS!HidpMajorHandler+0
fffff880`05f36710 48895c2410 mov qword ptr [rsp+10h],rbx

IRP_ADDRESS: fffff9800134ecf0

DEVICE_OBJECT: fffffa80068fa060

DRIVER_OBJECT: fffffa80068f88a0

IMAGE_NAME: tbs8921vhid.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 4cea108a

MODULE_NAME: tbs8921vhid

FAULTING_MODULE: fffff88005f30000 tbs8921vhid

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

PROCESS_NAME: System

CURRENT_IRQL: 2

LOCK_ADDRESS: fffff800036c9b60 -- (!locks fffff800036c9b60)

Resource @ nt!PiEngineLock (0xfffff800036c9b60) Exclusively owned
Contention Count = 2
NumberOfExclusiveWaiters = 1
Threads: fffffa800440c040-01<*>
Threads Waiting On Exclusive Access:
fffffa8004410680

1 total locks, 1 locks currently held

PNP_TRIAGE:
Lock address : 0xfffff800036c9b60
Thread Count : 1
Thread address: 0xfffffa800440c040
Thread wait : 0x627

LAST_CONTROL_TRANSFER: from fffff800039543dc to fffff800034cdd00

STACK_TEXT:
fffff880`02fd30f8 fffff800`039543dc : 00000000`000000c9 00000000`0000023b fffff880`05f36710 fffff980`0134ecf0 : nt!KeBugCheckEx
fffff880`02fd3100 fffff800`0395e47a : fffff800`039529f0 fffff880`05f36710 fffff980`0134ecf0 00000000`00000000 : nt!VerifierBugCheckIfAppropriate+0x3c
fffff880`02fd3140 fffff800`0395f483 : 00000000`0000023b 00000000`c0000010 fffff980`0134ecf0 00000000`ffffffff : nt!ViErrorFinishReport+0xda
fffff880`02fd3190 fffff800`0395fb42 : fffff980`0134ef28 fffff880`05f36710 00000000`00000000 00000000`000001f1 : nt!VfErrorReport1+0x63
fffff880`02fd3230 fffff800`03954071 : fffffa80`05f978f0 00000000`00000001 00000000`00000000 fffff980`0134ef28 : nt!ViGenericVerifyIrpStackUpward+0x62
fffff880`02fd3260 fffff800`03960b2d : fffffa80`05663960 fffffa80`05f975d0 fffff980`0134ecf0 fffff980`0134ecf0 : nt!VfMajorVerifyIrpStackUpward+0x91
fffff880`02fd32a0 fffff800`0397250d : fffff980`0134ef28 fffff880`02fd3480 00000000`c0000010 fffff980`0134ef28 : nt!IovpCompleteRequest2+0xad
fffff880`02fd3310 fffff800`034d1091 : fffff980`0134ef2b fffff800`00000000 00000000`000000ff fffff880`00000005 : nt!IovpLocalCompletionRoutine+0x9d
fffff880`02fd3370 fffff800`0396a19f : fffff980`0134ecf0 fffff880`05f40400 fffffa80`068fa100 00000000`00000000 : nt!IopfCompleteRequest+0x3b1
fffff880`02fd3450 fffff800`034b38c2 : fffff880`00000013 fffff880`02fd3578 fffff980`0134ef28 fffffa80`068fa1b0 : nt!IovCompleteRequest+0x19f
fffff880`02fd3520 fffff880`05f36a0f : 00000000`00000000 fffffa80`068fa1b0 00000000`00000001 00000000`00000017 : nt!IopInvalidDeviceRequest+0x16
fffff880`02fd3550 fffff880`05f367fb : 00000000`00000000 fffffa80`068fa1b0 fffff980`0134ecf0 fffff880`02fd3600 : HIDCLASS!HidpIrpMajorDefault+0x8b
fffff880`02fd3590 fffff800`03970c16 : fffff980`00000002 fffff980`0134ecf0 00000000`00000002 fffff800`0396c37e : HIDCLASS!HidpMajorHandler+0xeb
fffff880`02fd3600 fffff800`0396fc42 : fffff980`0134ef70 00000000`00000002 fffffa80`068faf50 fffffa80`055fb530 : nt!IovCallDriver+0x566
fffff880`02fd3660 fffff800`03970c16 : fffff980`0134ecf0 00000000`00000002 fffffa80`068fae00 00000000`00000000 : nt!ViFilterDispatchPower+0x62
fffff880`02fd3690 fffff800`0396fd58 : fffff980`0134ecf0 fffffa80`068fae00 00000000`00000000 fffffa80`062cc300 : nt!IovCallDriver+0x566
fffff880`02fd36f0 fffff800`0396fe42 : fffffa80`068f6060 fffffa80`044255b0 fffffa80`068f6060 00000000`00000017 : nt!VfIrpSendSynchronousIrp+0xe8
fffff880`02fd3760 fffff800`0395cfaf : fffffa80`068f6d90 00000000`000007ff fffff800`036045b8 fffff800`03860a89 : nt!VfWmiTestStartedPdoStack+0x72
fffff880`02fd3800 fffff800`03577a22 : fffffa80`068f6d90 00000000`00000000 00000000`00000000 00000000`00000000 : nt!VfMajorTestStartedPdoStack+0x5f
fffff880`02fd3830 fffff800`038b504c : fffffa80`068f6d90 fffffa80`044255b0 00000000`00000001 00000000`00000002 : nt!PpvUtilTestStartedPdoStack+0x12
fffff880`02fd3860 fffff800`038b6c44 : fffffa80`068f6d90 fffffa80`068f6d90 fffffa80`044255b0 00000000`00000001 : nt!PipProcessStartPhase3+0x55c
fffff880`02fd3950 fffff800`038b712c : fffff800`036c7400 00000000`00000000 00000000`00000000 00000000`00000000 : nt!PipProcessDevNodeTree+0x264
fffff880`02fd3bc0 fffff800`035c7902 : 00000001`00000003 00000000`00000000 00000000`32706e50 00000000`00000084 : nt!PiProcessStartSystemDevices+0x7c
fffff880`02fd3c10 fffff800`034d8021 : fffff800`035c7600 fffff800`037c4001 fffffa80`0440c000 00000000`00000000 : nt!PnpDeviceActionWorker+0x302
fffff880`02fd3cb0 fffff800`0376a32e : 00000000`00000000 fffffa80`0440c040 00000000`00000080 fffffa80`039f1040 : nt!ExpWorkerThread+0x111
fffff880`02fd3d40 fffff800`034bf666 : fffff880`009e6180 fffffa80`0440c040 fffff880`009f0f40 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
fffff880`02fd3d80 00000000`00000000 : fffff880`02fd4000 fffff880`02fce000 fffff880`02fd24f0 00000000`00000000 : nt!KiStartSystemThread+0x16


STACK_COMMAND: kb

FOLLOWUP_NAME: MachineOwner

FAILURE_BUCKET_ID: X64_0xc9_23b_VRF_IMAGE_tbs8921vhid.sys

BUCKET_ID: X64_0xc9_23b_VRF_IMAGE_tbs8921vhid.sys

Followup: MachineOwner
---------
philerup
 
Posts: 1
Joined: Sun Jun 26, 2011 6:29 am

Re: Blue screen with APC index mismatch error

Postby steven » Mon Jun 27, 2011 5:28 pm

satelay Wrote:Hi Steven, I am now on vacation and do not have access to either of the two machines that had problems with this card. So I am afraid I can't try your hotfix until the end of August and you will need to work with others who are having the same problem. I am surprised though, it was missed that the problem shows up under both 32 and 64 bit versions of W7 which I had clearly indicated before. Just to wrap up, the following points are the facts that I have gathered so far and may be useful in isolating the problem.

1. Problem seems to be specific to some Gigabyte MBs as reported in previous posts. Examples are: GIGABYTE GA-880GMA-UD2H and GA-MA785GM-US2H
2. Problem seems to be specific to W7 and shows up under both 32 and 64 bit versions
3. Problem is not processor dependent and shows up with both AMD and Intel processors
4. Problem seems to be specific to the TBS 8921 card/driver because TBS 6981 runs in the same machine without any problems.
5. Another thing worth mentioning is that both of my machines which had this problem are built inside an Antec fusion HTPC box which has an LCD screen, an IR remote and run the IMON manager software and related drivers. This may be causing some conflict.

I hope this is helpful. Good luck isolating the problem.

Hi really thanks for your advice.
We will try our best to solve this
Thanks. :)
steven
 
Posts: 2199
Joined: Fri Aug 06, 2010 3:23 pm

Re: Blue screen with APC index mismatch error

Postby steven » Mon Jun 27, 2011 5:43 pm

Hi all
From
nikos1671 Wrote:Hi,
Before 2 days i bough also the 8921.

But i have also the same problem BSOD, one time happened when i wake up my pc from sleep mode and i try to tune to one channel ,also more than 3 or 4 times in 2 day that i have this card i had BSOD when i was zapping to channels.
I have try another pci slot but the same results.
My mobo is Gigabyte 880GM-UD2H.
Any suggestions any help???


and


satelay Wrote:It is not unusual that one wants to scan two or more transponders in a row. However, the bluescreen seems to be random and sometimes it comes in the first scan. I have tried 8921 driver v1.0.0.4 on another W7 machine. In fact it was a 32 bit version, not 64 as I first thought. It had different hardware with a different Gigabyte MB. After installing only the driver and the version of DVB Dream supplied on the installation disk, I have started a scan of Hotbird. Right in the middle of the scan I got the blue screen. After rebooting the machine, I have started the same scan one more time and it succeeded. That suggests that there really is something wrong with the driver under W7 and it appears to be completely random. I am sure if you try to do a few scans which take a relatively long time, you will definitely reproduce the bug with the blue screen.


That when scan two or more transponders or wake up, it will give BSOD.
So anyone have BSOD beside this.

Thanks
steven
 
Posts: 2199
Joined: Fri Aug 06, 2010 3:23 pm

Re: Blue screen with APC index mismatch error

Postby satelay » Tue Jun 28, 2011 12:27 am

Blue screens are random and do come during scans (usually lengthy scans) and also while tuning or changing channels. So far it has been reported on 3 different Gigabyte MBs.
satelay
 
Posts: 11
Joined: Thu Jun 02, 2011 3:22 pm

Re: Blue screen with APC index mismatch error

Postby steven » Tue Jun 28, 2011 5:39 pm

Hi all
Latest about the BSOD on TBS8921, we are very concerned about this matter,
here is the new driver which solved wake up BSOD problem,and some other change,that need you to have a test.
http://hotfile.com/dl/122451884/aa601b2 ... 7.rar.html
Really thanks for your test .
We will appreciate that you can send your test report.

Thanks
steven
 
Posts: 2199
Joined: Fri Aug 06, 2010 3:23 pm

Re: Blue screen with APC index mismatch error

Postby nikos1671 » Tue Jun 28, 2011 7:45 pm

first tests are good no BSOD when pc weak up from sleep,no BSOD when zapping.First impressions are good.
Still need some more test for the last conclusions.
Thanks a lot for the fast react Steven.
p.s.
Now i have a question for you,i am planing to buy the dual tuner TBS-6981,do you think i will have again problems with my mobo??or this drivers are good right now??
Nikos
nikos1671
 
Posts: 14
Joined: Thu Jun 23, 2011 7:17 pm

Re: Blue screen with APC index mismatch error

Postby steven » Wed Jun 29, 2011 9:23 am

nikos1671 Wrote:first tests are good no BSOD when pc weak up from sleep,no BSOD when zapping.First impressions are good.
Still need some more test for the last conclusions.
Thanks a lot for the fast react Steven.
p.s.
Now i have a question for you,i am planing to buy the dual tuner TBS-6981,do you think i will have again problems with my mobo??or this drivers are good right now??
Nikos

Hi
really thanks for your test report.any another people is good too?
Thanks
steven
 
Posts: 2199
Joined: Fri Aug 06, 2010 3:23 pm

Re: Blue screen with APC index mismatch error

Postby 0935 » Sat Feb 20, 2016 12:33 am

Hi.
I know this topic is old but I had this problem too.
To solve the problem, Just open Dvbdream and go to: option/ preferences/performance then check the "delay for stability while channel changing" and set it to at least 500 ms or more. The more "ms" the better stability and the more time on channel changing.
There is an option on Progdvb too. called "speed of channel changing" just set it to slow.
Hope this help.
0935
 
Posts: 3
Joined: Tue Dec 30, 2014 10:27 pm

Previous

Return to Windows

Who is online

Users browsing this forum: No registered users and 2 guests