Page 1 of 1

IRQ errors

PostPosted: Wed Apr 04, 2012 1:40 am
by briogoog
On four occasions now I find my system is very slow, dvb recordings fail and I get this message in the log :- see attached log file for more:-

Apr 2 08:13:49 linux-kdjx kernel: [291560.437667] irq 16: nobody cared (try booting with the "irqpoll" option)
Apr 2 08:13:49 linux-kdjx kernel: [291560.437673] Pid: 0, comm: kworker/0:0 Tainted: P 3.1.9-1.4-desktop #1
Apr 2 08:13:49 linux-kdjx kernel: [291560.437675] Call Trace:
Apr 2 08:13:50 linux-kdjx kernel: [291560.437787] [<ffffffffa02173f0>] azx_interrupt
Apr 2 08:13:50 linux-kdjx kernel: [291560.437792] [<ffffffffa02048f0>] saa716x_tbs6280_pci_irq
Apr 2 08:13:50 linux-kdjx kernel: [291560.437793] Disabling IRQ #16

Rebooting fixes the issue and it usually ok again for a few days, This happened on my suse 11.2 32 bit and has also happened three times on the 64 bit suse 12.1 I upgraded to. From the log message I'm wondering if this is to do with the 6280 drivers?

Re: IRQ errors

PostPosted: Wed Apr 04, 2012 3:33 am
by SergioDanielG
It's like a problem sharing irq.
Can you post information about your motherboard, graphic card and can you try move tbs6280 to another pci slot?

Best regards.

Re: IRQ errors

PostPosted: Wed Apr 04, 2012 7:22 am
by briogoog
MBs a M3A78-EM, GFx is GeForce 210 NVIDIA Driver Version: 295.33
only one 1x pcix slot and one 16x pcix slot on this board though - so no chance to swap cards.
i've not seen this problem until the last tbs combined hd/sd driver.

cat /proc/interrupts
0: 3960445 81633558 IO-APIC-edge timer
1: 592 7810 IO-APIC-edge i8042
8: 0 1 IO-APIC-edge rtc0
9: 0 0 IO-APIC-fasteoi acpi
14: 18025 90232 IO-APIC-edge pata_atiixp
15: 0 0 IO-APIC-edge pata_atiixp
16: 916858 10737895 IO-APIC-fasteoi ohci_hcd:usb3, ohci_hcd:usb4, snd_hda_intel, SAA716x Core
17: 1214194 13496253 IO-APIC-fasteoi ehci_hcd:usb1, firewire_ohci
18: 332181 2711313 IO-APIC-fasteoi ohci_hcd:usb5, ohci_hcd:usb6, ohci_hcd:usb7, snd_hda_intel, nvidia
19: 74862 1018793 IO-APIC-fasteoi ehci_hcd:usb2
21: 0 0 IO-APIC-fasteoi cx88[0], cx88[0]
22: 111400 2376553 IO-APIC-fasteoi ahci
44: 35317 805715 PCI-MSI-edge eth0
NMI: 1792 1875 Non-maskable interrupts
LOC: 63742350 25932804 Local timer interrupts
SPU: 0 0 Spurious interrupts
PMI: 1792 1875 Performance monitoring interrupts
IWI: 0 0 IRQ work interrupts
RES: 29563824 27021574 Rescheduling interrupts
CAL: 149279 137886 Function call interrupts
TLB: 124727 117557 TLB shootdowns
TRM: 0 0 Thermal event interrupts
THR: 0 0 Threshold APIC interrupts
MCE: 0 0 Machine check exceptions
MCP: 356 356 Machine check polls
ERR: 0
MIS: 0

Re: IRQ errors

PostPosted: Sun Apr 29, 2012 5:45 am
by colin
i'm getting the same error having upgraded to the combined driver.
i just tried upgrading to the latest 120412 driver but same problem.

it was ok using the previous drivers and is ok again for a few days after a reboot.
my motherboard is similar: M5A88-M EVO AM3+ AMD 880G DDR3 mATX

the IRQ error i get is.
[96240.913566] irq 17: nobody cared (try booting with the "irqpoll" option)
[96240.913571] Pid: 0, comm: kworker/0:0 Tainted: P 3.0.0-17-generic-pae #30-Ubuntu
[96240.913621] handlers:
[96240.913633] [<f85589e0>] saa716x_tbs6280_pci_irq
[96240.913634] Disabling IRQ #17

Re: IRQ errors

PostPosted: Sun Apr 29, 2012 6:29 am
by marks7389
I'm also seeing exactly the same error on an Asus AT5IONT-I motherboard (second generation nVidia ION). Only one PCIe slot, so no possibility of moving it.

Had been working fine for a month and a half, but the issue his hit me twice in five days. It is also IRQ#17 on mine; nothing else is sharing it:

17: 1364271 2825469 4312887 1797374 IO-APIC-fasteoi SAA716x Core

Annoying since has lost me several recordings....

Re: IRQ errors

PostPosted: Mon Apr 30, 2012 7:36 pm
by cody
one of our customers pointed me out to this thread and because i gave him some suggestion i'm posting copy of my reply to him and thus others with such issue can try the same suggestion:

we can be quite sure that problem is related to your environment, i.e. it could be your motherboard or with which devices your 6280 card is sharing IRQs, etc, because we have customers that are IPTV providers and thus running those TBS cards on 24/7 basis in Linux and there are no such problem. so, it's not a general problem and based on that it's IRQ-related it's less likely there is anything we can do in the drivers as far as IRQ are in use (it will become more clear what i mean later in this email).

it could be as simple as that your motherboard is not able to process correctly IRQ interrupts in Linux (which is the legacy way of dealing with interrupts), but it's working good with MSI interrupts (which is the modern way of dealing with interrupts introduced with PCI-Express). so, 6280 is modern hardware with modern Linux driver and it supports both old IRQ interrupts and Message Signal Interrupts (MSI) and thus you can try with using MSI instead IRQ and there is good chance that will get rid of the problem. so, MSI can be activated instead IRQ
in the driver in the following way:

- create file called for example "tbs.conf" in "/etc/modprobe.d" with content like this:

# cat /etc/modprobe.d/tbs.conf

options saa716x_tbs-dvb int_type=1

and then reboot to load the driver with the MSI interrupt support enabled, more details about that option can be found in:


unsigned int int_type;
module_param(int_type, int, 0644);
MODULE_PARM_DESC(int_type, "force Interrupt Handler type: 0=INT-A,
1=MSI, 2=MSI-X. default INT-A mode");

so, that's what i can suggest to try/test and see if it solves the problem.

Re: IRQ errors

PostPosted: Sat May 05, 2012 5:33 am
by delboy711
I get the same problem. Also using Asus AT5IONT-I
Code: Select All Code
May  4 16:31:11 mail kernel: irq 17: nobody cared (try booting with the "irqpoll" option)
May  4 16:31:11 mail kernel: [<ffffffff81745cae>] ? start_kernel+0x3fa/0x405
May  4 16:31:11 mail kernel: [<ffffffff8174532b>] ? x86_64_start_reservations+0x132/0x136
May  4 16:31:11 mail kernel: [<ffffffff81745435>] ? x86_64_start_kernel+0x106/0x115
May  4 16:31:11 mail kernel: Disabling IRQ #17

After todays failure I have enabled MSI
Code: Select All Code
 cat /proc/interrupts
            CPU0       CPU1       CPU2       CPU3       
  59:          7          2          8          1   PCI-MSI-edge      SAA716x Core

Now to wait for a few days to see if it has made a difference.

Re: IRQ errors

PostPosted: Sat May 05, 2012 6:24 am
by SergioDanielG
Yesterday, TBS publish a new version of linux drivers. One of modification is in tbs62x0fe_driver_dvbc. Changes not necessarily about your problem, but would you like to try it?

Best regards.

Re: IRQ errors

PostPosted: Sat May 12, 2012 6:52 am
by colin
i was getting the IRQ errors...

i made the change to enable MSI instead of IRQ using the suggested tbs.conf change above.

it's been working ok for over a week now, without having to reboot, so I'm confident it's fixed the IRQ error for me.

Re: IRQ errors

PostPosted: Wed May 16, 2012 3:16 am
by briogoog
MSI interrupt support enabled, now 14 days without any IRQ errors.