Moderator Control Panel ]

Linux kernel 5.18

It's important to keep your driver and software updated.

Linux kernel 5.18

Postby hasecomp » Thu Jun 09, 2022 9:08 pm

Please allow me to mention that there are issues with the Open Source Linux Driver when using Linux kernel 5.18.

Linux 5.18.1-arch1-1:

/home/andre/media_build/v4l/msi001.c:504:27: error: initialization of 'void (*)(struct spi_device *)' from incompatible pointer type 'int (*)(struct spi_device *)' [-Werror=incompatible-pointer-types]
504 | .remove = msi001_remove,
| ^~~~~~~~~~~~~
/home/andre/media_build/v4l/msi001.c:504:27: note: (near initialization for 'msi001_driver.remove')
cc1: some warnings being treated as errors
make[3]: *** [scripts/Makefile.build:288: /home/andre/media_build/v4l/msi001.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [Makefile:1834: /home/andre/media_build/v4l] Error 2
make[2]: Leaving directory '/usr/lib/modules/5.18.1-arch1-1/build'
make[1]: *** [Makefile:53: default] Error 2
make[1]: Leaving directory '/home/andre/media_build/v4l'
make: *** [Makefile:26: all] Error 2


Linux 5.18.2-arch1-1:

/home/andre/media_build/v4l/msi001.c:504:27: error: initialization of 'void (*)(struct spi_device *)' from incompatible pointer type 'int (*)(struct spi_device *)' [-Werror=incompatible-pointer-types]
504 | .remove = msi001_remove,
| ^~~~~~~~~~~~~
/home/andre/media_build/v4l/msi001.c:504:27: note: (near initialization for 'msi001_driver.remove')
cc1: some warnings being treated as errors
make[3]: *** [scripts/Makefile.build:288: /home/andre/media_build/v4l/msi001.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [Makefile:1834: /home/andre/media_build/v4l] Error 2
make[2]: Leaving directory '/usr/lib/modules/5.18.2-arch1-1/build'
make[1]: *** [Makefile:53: default] Error 2
make[1]: Leaving directory '/home/andre/media_build/v4l'
make: *** [Makefile:26: all] Error 2

As far as I'm concerned, you need not hurry with submitting an update of the driver, since I downgraded my Arch Linux to Linux kernel 5.17.9.

My TBS card is a TBS6281SE, but this is probably not relevant in this context.

Kind regards,
Andre Hasekamp.
hasecomp
 
Posts: 9
Joined: Mon Nov 27, 2017 8:57 pm

Re: Linux kernel 5.18

Postby zhangchao » Thu Jun 16, 2022 2:41 pm

hi,
please add skype jack_2431. or write email to support@tbsdtv.com
best regards!
zhangchao
 
Posts: 78
Joined: Thu Jan 17, 2013 4:59 pm

Re: Linux kernel 5.18

Postby fe31nz » Thu Jun 23, 2022 4:51 pm

There is a patch to fix this, but it has not been merged into the main code yet. See:

https://github.com/tbsdtv/linux_media/issues/286#issuecomment-1163438727
fe31nz
 
Posts: 1
Joined: Sun Apr 16, 2017 12:02 am


Return to Driver & Software Update

Who is online

Users browsing this forum: No registered users and 2 guests