Moderator Control Panel ]

TBS5580 Win 10x64 driver

It's important to keep your driver and software updated.

TBS5580 Win 10x64 driver

Postby tsygam » Sun Jan 28, 2018 10:45 pm

Hi!

I'm trying to use TBS5580 with Mediaportal. For some reason 5580 does not scan automatically muli-PLP in DVB-T2 (in SmartDVB it also does not see multiPLP automatically, but does see if multiPLP is scanned manually). Is it driver or DVB software (Mediaportal) issue?

Also, how can DVB software (Mediaportal, SmartDVB, etc) switch between DVB-S/S2 and DVB-T/T2, is it possible to do this by driver and not by any change mode external utility?

Thank you and regards,

Max
tsygam
 
Posts: 10
Joined: Fri Sep 22, 2017 1:01 am

Re: TBS5580 Win 10x64 driver

Postby steven » Mon Jan 29, 2018 10:08 am

Hi tsygam

In DVBDream for PLP channels you can scan first the second time you can easy to watch , for auto change DVB-T and DVBS the player can not do it
you need to use our change mode tool to change the mode

Thanks

Kind Regards

steven
steven
 
Posts: 2036
Joined: Fri Aug 06, 2010 3:23 pm

Re: TBS5580 Win 10x64 driver

Postby tsygam » Mon Jan 29, 2018 1:58 pm

Hi, thank you.

For DVBdream I understand, but how multi PLP should work in Mediaportal (double search does not work for 5580, though multiPLP works in Mediaportal for some other TBS card)?

Can you please provide mode change in .exe without GUI and also just a .dll. May be one for all such cards would be a good option.

Regards,
Max
tsygam
 
Posts: 10
Joined: Fri Sep 22, 2017 1:01 am

Re: TBS5580 Win 10x64 driver

Postby DVB » Sun Jun 30, 2019 8:56 am

Anybody had faced packet lost issues with 5580? On current Windows driver at different PC's (USB 3.0) I see very regular packet loses with repeatable pattern.
Every 1:30 ~100 packets from a ~61,2 Mbit/s stream (standard DVB-S2/8PSK with SR 27500 ksymb/s and FEC 3/4) and additionally another 100 packets 30 secs later.
Further loses with similar pattern 1:30, 0:30, 1:30, 0:30.

I can put some sample screeenshots later.

Very annoying issue.
Last edited by DVB on Tue Aug 13, 2019 5:10 am, edited 1 time in total.
DVB
 
Posts: 85
Joined: Sun Apr 17, 2011 8:02 am

Re: TBS5580 Win 10x64 driver

Postby klosz007 » Mon Aug 12, 2019 7:16 am

I have a problem with 5580 too.

Win 10 x64 1903 + TBS5580 driver 1.0.0.3 + my DVB-C cable provider's CI module + DVBViewer 6.1.5

Playback of DVB-C channels starts fine, after some time (~20-30 secs ?) playback stops, after a couple of seconds playback resumes again, then again it stops etc. etc. Sometimes it hangs completely (DVBViewer closes itself) and I have to powercycle 5580 to revive it.
I tried to use it with unencrypted DVB-T FTA channels but then I'm not even able to scan channels. DVBViewer self closes (after finding only some channels), before the scan even completes.

Everything was OK with TBS5881 but this box started to hang randomly during long usage periods at recent period of very hot weather (probably something overheated inside). Even though temperatures returned to normal, it is still hanging sometimes. So I have to find a replacement.
I bought 5580 but so far I cannot make it work.
klosz007
 
Posts: 8
Joined: Thu Jun 01, 2017 6:21 pm

Re: TBS5580 Win 10x64 driver

Postby DVB » Tue Aug 13, 2019 4:54 am

For me after further investigation it seems that this is USB 3.0 issue.

@klosz007 - are you using CAM? Try to extract CAM for a while, then scan, check FTA. You are on USB 3.0? If so - try USB 2.0.
A part of DVB Viewer is TransEdit app - try to download it from DVB Viewer members area, lock any frequency and sort results by 'Missing' column.

@steven - do you have maybe any beta version for Windows? We can check if there is any progress.
IMHO in Windows drivers there's some bug related to USB 3.0 which will result in missing packets. Visible result of it is regular stuttering (with repeats on regular time) and eventually crash of DVB app.
DVB
 
Posts: 85
Joined: Sun Apr 17, 2011 8:02 am

Re: TBS5580 Win 10x64 driver

Postby klosz007 » Fri Aug 16, 2019 7:14 am

Hi,

It's hard to find true USB 2.0 ports these days. I have some USB 2.0 ports in my PC but in Device Manager they are still reported to be connected to Intel USB 3.0 controller, no idea why (Intel X299 chipset).
On another PC (Intel NUC) I have Intel USB 3.0 ports only...

Issue is the same no matter whether tuner is connected to Intel USB 2.0/3.0 (3.1 Gen 1) or Asmedia USB 3.1 (3.1 Gen 2) ports.
It's not a USB cable issue becuase finally I was able to set up 5580 under Linux and no matter which USB port is used, it's working fine, on the same USB cable (I tried other cables too, no change).
So it's something wrong in Windows 5580 drivers, possibly related to USB 3.0.

Interesting that 5580 uses the same CPU as 5881 (CY7C68013A) and 5581 worked fine in same configurations. So again - it's a driver/firmware problem.


Problem is the same with FTA DVB-T channels so I see no correlation to CI (yes, I'm using CAM for DVB-C channels)

Even it's a USB 3.0 problem and true 2.0 ports would help, it's no relief for me becuase my TV server is Intel NUC with 3.0 ports only.

Update:
I tested it on my wife's laptop, it has USB 2.0 port but again it belongs to Intel USB 3.0 controller, like on my PC. It has the same problem.
klosz007
 
Posts: 8
Joined: Thu Jun 01, 2017 6:21 pm

Re: TBS5580 Win 10x64 driver

Postby DVB » Sat Aug 17, 2019 8:17 am

Thanks for additional tests.

TBS5520SE is also unsing the same bridge (CY7C68013A) and it is working fine on Windows (tested).

I've got older PC at home with USB 2.0 and there 5580 with latest drivers 1.0.0.3 is working fine, no freezes after ~60 mins session. But at laptop with USB 3.0 only - issue is visible in less than minute (with the same 5580, on the same PSU and the same USB cable).

Definitely 5580 Windows drivers bug. It could be introduced later, didn't check yet older 1.0.0.1 and 1.0.0.2 releases, but I'm not sure is there any sense to do that, because going back may bring back some old bugs.

Probably nothing much can be done right now, beside waiting for 1.0.0.4 release...

@steven - can you help us? With 1.0.0.3 drivers 5580 is nearly unusable in some cases in Windows environment. :cry:
DVB
 
Posts: 85
Joined: Sun Apr 17, 2011 8:02 am

Re: TBS5580 Win 10x64 driver

Postby klosz007 » Sat Aug 24, 2019 2:59 am

I had remote support session today and it seems like a software problem but hard to tell where.

Both DVBViewer and DVBDream experience exactly the same problem.
Support tested DVBDream only on one PC only but I tested this myself on two PCs with DVBViewer and DVBDream AND two other PCs with DVBViewer only, with same results.
Common part of all PCs is Windows 10 1903 x64 and USB 3.0.
DVBViewer clearly logs periodic packet losses (approx every 30 secs).

To my surprise built-in viewer into DVBViewer's TransEdit does NOT experience this issue (!) while DVBViewer itself does.
TBS5580 also works very well on the same PC under Linux so it's not a PC/cable/USB 3.0 port issue.
It must be software bug somewhere. Either in 5580 Windows driver or DVBDream/DVBViewer do not like this driver.

Support colleague was suspecting LAV codecs but on the same OS/hardware/codecs configuration 5881 works flawlessly.
Microsoft codecs experience same issue.
Support coleague also tried older 5580 1.0.0.2 driver and older TBSCIApi.dll - same thing.
Logs were collected and will be sent to DVBDream developer (personally I would suggest contacting DVBViewer team too).
DVBProg couldn't be tested - since it detected DVB-S/LNB, it didn't allow use on free license.


Nevertheless, I purchased 5580 to replace my 2-year old 5881 which started to fail (it hangs randomly, the more frequently the hotter it is - temperature related issue).
So I bought 5580 to replace that old 5881 but eventually, due to these unresolvable problems, I decided to return 5580 to the seller. Instead, luckily I was able to find one piece of new 5881 which works perfectly under Windows (I think 5881 is no longer manufactured ? It is hard to find now.).
I'm not really willing to switch to Linux to be able to use 5580. Too much complication. And 5580 is 50% more expensive than 5881.
klosz007
 
Posts: 8
Joined: Thu Jun 01, 2017 6:21 pm

Re: TBS5580 Win 10x64 driver

Postby klosz007 » Sat Aug 24, 2019 3:44 am

One more thing just to proove how capricious these devices can be.
That old 5881 that is failing now - I was using it with MSI Cubi mini PC with Pentium 3805U CPU.
But then I wanted more CPU power to be able to stream/transcode TV to iPad and I bought second hand Intel NUC7i7BNH with some 4-core i7.
And immeidately I started having problems with 5881.

It was able to play TV programme for let's say an hour, then I was receiving long streams of massive amount of packet drops/errors - unwatchable block noise. It lasted for some time (say 30 minutes), then self gone. And again, and again.
I couldn't return that NUC so I was thinking about purchasing a new tuner.
But got a bright idea - I connected that old 5881 to NUC via USB 3.0 hub - then it worked flawlessly... Why ?

This 5580 and new 5881 - both work well (5580 under Linux only and 5881 under Linux/Windows) with this Intel NUC directly attached (no hub needed).
klosz007
 
Posts: 8
Joined: Thu Jun 01, 2017 6:21 pm

Next

Return to Driver & Software Update

Who is online

Users browsing this forum: No registered users and 1 guest