Page 2 of 2

Re: TBS5580 Win 10x64 driver

PostPosted: Sat Aug 24, 2019 9:28 pm
by DVB
For me issue is visible on both DVBViewer and TransEdit and also on other software, like AltDVB - it's hard for me to believe that all developers have made the same mistake in their apps and only for some PC. But it's worth to check this path...
Unfortunately I cannot lend my PC for a support session.
If there won't be any solution for this, I'm going to return this device aswell and maybe switch to 5520SE, which seems to be free from this issue. I'm often recording some data feeds where missing packet is leading to failure of reading whole message. Because of that I can use 5580 only on one from my PC's, but for it I've got already other DVB card. Right now this bug is making my 5580 useless.

Re: TBS5580 Win 10x64 driver

PostPosted: Wed Jun 03, 2020 5:35 pm
by adipetroiu
Hi!
I tried to use the tuner for satellite TV encrypted with a CAM Conax.
I tried a lot of software but to no result. Dvb dream and Dvb viewer crashes, Prog dvb dont decrypt, tbs viewer decrypt and find only a few encrypted channels. Cam anyone help me?
Mceci tool see the cam module, the tv provider is Focus sat Romania, it use Thor 6 satellite. I have windows 10 home edition.

Re: TBS5580 Win 10x64 driver

PostPosted: Sat Jun 06, 2020 10:02 am
by steven
Hi adipetroiu

Next Monday can you setup teamview remote with DVBDream we will check together

Thanks

Kind Regards

steven

Re: TBS5580 Win 10x64 driver

PostPosted: Wed Jun 17, 2020 11:15 pm
by fatal
adipetroiu Wrote:Hi!
I tried to use the tuner for satellite TV encrypted with a CAM Conax.
I tried a lot of software but to no result. Dvb dream and Dvb viewer crashes, Prog dvb dont decrypt, tbs viewer decrypt and find only a few encrypted channels. Cam anyone help me?
Mceci tool see the cam module, the tv provider is Focus sat Romania, it use Thor 6 satellite. I have windows 10 home edition.


Same here. The problem is in the CI API DLL (v1.0.2.2 and v1.0.2.3).

Here is my conclusion:

I use DVB-C, QAM256 and SymbolRate is 6875 (I don't know if it matters)

I've tried different softwares, the issue is clearly the CI API DLL:
  • TBSViewer (which is DVBViewer based as far as I know) is using 1.0.2.0 CI API DLL which works fine
  • TVMosaic's current version also using 1.0.2.0 DLL and works fine
  • Latest DVBViewer uses 1.0.2.2, scanning currently works, but watching an encrypted channel crashes the player after a few minutes
    • I've tried to overwrite the DLL with the 1.0.2.0, but it doesn't work, I guess it uses an updated code which only works with the 1.0.2.2 CI API DLL
  • In MediaPortal we manually need to copy the dll
    • If I copy 1.0.2.0, scanning works but MediaPortal cannot decode with 1.0.2.0, I guess it uses an updated code which only works with 1.0.2.2 or 1.0.2.3
    • If I copy 1.0.2.2 or 1.0.2.3, TVService (and TV-Server Configuration) crashes while scanning channels
    • If I scan without a DLL (or old version) it scans the channels
    • If I copy the DLL after scanning, the channel playback in the client freezes for a couple of seconds in every few minutes
I didn't try other clients cause this clearly shows what is the issue here. Also sometimes during scan it doesn't found the channels on multiple transponders, but if I run it again, it finds them (but fails to find them on another frequency, it's random, sometimes every channel is found). This issue is present even in TBSViewer.

Can we expect an update for the CI DLL and/or the driver which fixes these issues?