Page 1 of 1

Centos 7 with kernel 3.10.0- problem

PostPosted: Fri Aug 30, 2019 5:31 pm
by gbgb
I've Centos 7 1810, with kernel 3.10.0-957.el7.x86_64, I was unable to install TBS Open Source Linux Driver Offline Package V190521. I tried with ./ script, and manual.
When I run command: make -j4
I’m getting following error:
patch -s -f -N -p1 -i ../backports/v4.3_bt87x_const_fix.patch
1 out of 1 hunk FAILED
make[2]: *** [apply_patches] Error 1
make[2]: Leaving directory `/root/tbsdriver/media_build/linux'
Preparing to compile for kernel version 3.10.0
File not found: /lib/modules/3.10.0-957.el7.x86_64/build/.config at ./scripts/ line 33, <IN> line 4.
make[1]: *** No rule to make target `.config', needed by `.myconfig'. Stop.
make[1]: Leaving directory `/root/tbsdriver/media_build/v4l'
make: *** [all] Error 2

please suggest, how to use DVB-S2/DVB-T2 cards on newest Centos 7 version.

Thank you in advance.

Re: Centos 7 with kernel 3.10.0- problem

PostPosted: Fri Aug 30, 2019 6:02 pm
by gbgb
from if someone has similar problem, you can with with update kernel to 4.X and install driver. you can you manual here:

1. Update to new kernel
2. #rpm --import
3. #rpm -Uvh ... noarch.rpm
4. #yum --enablerepo=elrepo-kernel install kernel-lt-devel kernel-lt -y
5. #grub2-set-default 0
6. Restart to load the new kernel and install gcc unzip
7. #yum -y install gcc
8. #yum -y install unzip
9. #reboot
10. Install required libraries
11. #yum -y install perl-devel perl-ExtUtils-CBuilder perl-ExtUtils-MakeMaker
12. #yum -y install patchutils
13. #yum -y install patch
14. Install the SHA
15. #wget ... z/download -O Digest-SHA-5.93.tar.gz
16. #tar xvf Digest-SHA-5.93.tar.gz
17. #cd Digest-SHA-5.93
18. #perl Makefile.PL
19. #make && make install
20. Install Perl
21. #wget ... p/download -O
22. #unzip
23. #cd perl-proc-processtable-master
24. #perl Makefile.PL
25. #make && make install
26. Start install the open source driver, then start install the driver.