Moderator Control Panel ]

TXFIFO not empty after Timeout, tried 1000 loops!

It's important to keep your driver and software updated.

TXFIFO not empty after Timeout, tried 1000 loops!

Postby Spinaker » Thu Apr 25, 2013 1:06 pm

Intel® Core™ i5-3550 CPU @ 3.30GHz stepping 09
Gigabyte Technology Co., Ltd. To be filled by O.E.M./Z77X-D3H, BIOS F18c 03/11/2013 (Latest bios version!)

Linux streamer-s1 3.2.0-0.bpo.4-amd64 #1 SMP Debian 3.2.41-2~bpo60+1 x86_64 GNU/Linux

TBS6985 + Drivers v130318 (64bit)

Code: Select All Code
01:00.0 Multimedia controller [0480]: Philips Semiconductors SAA7160 [1131:7160] (rev 02)
        Subsystem: Device [6985:0002]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 46
        Region 0: Memory at f7d00000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: [40] MSI: Enable+ Count=1/32 Maskable- 64bit+
                Address: 00000000fee0800c  Data: 41a1
        Capabilities: [50] Express (v1) Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <256ns, L1 <1us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
                LnkCap: Port #1, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <4us, L1 <64us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
        Capabilities: [74] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [80] Vendor Specific Information: Len=50 <?>
        Kernel driver in use: SAA716x TBS


Code: Select All Code
Apr 25 11:54:11 streamer-s1 kernel: [160093.921258] saa716x_i2c_hwinit (0): Adapter (c000) SAA716x I2C Core 1 RESET
Apr 25 11:56:08 streamer-s1 kernel: [160209.905420] saa716x_i2c_send (0): TXFIFO not empty after Timeout, tried 1000 loops!
Apr 25 11:56:08 streamer-s1 kernel: [160209.905452] saa716x_i2c_send (0): I2C Send failed (Err=-5)
Apr 25 11:56:08 streamer-s1 kernel: [160209.905469] saa716x_i2c_xfer (0): Data send failed
Apr 25 11:56:08 streamer-s1 kernel: [160209.905491] saa716x_i2c_hwinit (0): Adapter (c000) SAA716x I2C Core 1 RESET
Apr 25 11:57:01 streamer-s1 kernel: [160263.036005] saa716x_i2c_send (0): TXFIFO not empty after Timeout, tried 1000 loops!
Apr 25 11:57:01 streamer-s1 kernel: [160263.036036] saa716x_i2c_send (0): I2C Send failed (Err=-5)
Apr 25 11:57:01 streamer-s1 kernel: [160263.036054] saa716x_i2c_xfer (0): Data send failed
Apr 25 11:57:01 streamer-s1 kernel: [160263.036076] saa716x_i2c_hwinit (0): Adapter (b000) SAA716x I2C Core 0 RESET
Apr 25 11:57:08 streamer-s1 kernel: [160270.198304] saa716x_i2c_send (0): TXFIFO not empty after Timeout, tried 1000 loops!
Apr 25 11:57:08 streamer-s1 kernel: [160270.199602] saa716x_i2c_send (0): I2C Send failed (Err=-5)
Apr 25 11:57:08 streamer-s1 kernel: [160270.199631] saa716x_i2c_xfer (0): Data send failed


Why is this happening?
Spinaker
 
Posts: 1
Joined: Tue Apr 23, 2013 3:08 am

Re: TXFIFO not empty after Timeout, tried 1000 loops!

Postby devicebusy » Tue Aug 06, 2013 9:36 pm

Same messages in log, system is ASUS Sabertooth 990FX R2.0 / AMD FX6300 / 2G ram + 2x TBS6985 + 1x TBS3102, Debian wheezy with 3.9. kernel from backports:
Linux streamer1 3.9-0.bpo.1-686-pae #1 SMP Debian 3.9.6-1~bpo70+1 i686 GNU/Linux
from debian repository:
root@streamer1:~# dpkg -l | grep linux-image
ii linux-image-3.9-0.bpo.1-686-pae 3.9.6-1~bpo70+1 i386 Linux 3.9 for modern PCs

TBS drivers are:
-rw-r--r-- 1 root root 15199793 Jul 29 10:53 tbs-linux-drivers_v130729.zip

root@streamer1:~# modinfo tbs6985fe
filename: /lib/modules/3.9-0.bpo.1-686-pae/kernel/drivers/media/dvb/frontends/tbs6985fe.ko
license: TurboSight Proprietary: www.tbsdtv.com
author: Konstantin Dimitrov <kosio.dimitrov@gmail.com>
description: TurboSight TBS 6985 DVBS/S2 frontend driver module
depends: i2c-core
vermagic: 3.9-0.bpo.1-686-pae SMP mod_unload modversions 686
devicebusy
 
Posts: 4
Joined: Fri Aug 02, 2013 3:55 pm

Re: TXFIFO not empty after Timeout, tried 1000 loops!

Postby devicebusy » Tue Aug 06, 2013 9:58 pm

BTW messages are begins in the log only when i have enabled this sysctl settings:

cat /etc/modprobe.d/tbs6985.conf
--------------------------------------------

options saa716x_tbs_dvb int_type=1
options saa716x_tbs_dvb verbose=1

options dvb_core dvb_shutdown_timeout=0
options dvb_core dvb_powerdown_on_sleep=0

i've never see this error before sysctl tuning
devicebusy
 
Posts: 4
Joined: Fri Aug 02, 2013 3:55 pm


Return to Driver & Software Update

Who is online

Users browsing this forum: No registered users and 2 guests