Moderator Control Panel ]

MOI Startup Process

Anything from the case design to the chip inside, from expectation to suggestion, the most important thing is, you are IN.

MOI Startup Process

Postby jarmen » Sat Jul 20, 2013 3:23 am

Hi All,
I have two dvblast commands to stream two transponders. When I execute them, everythin is ok.
But I want to start automatically on startup.

I tried a lot of ways:
-Crontab is not working (No such file...., but I fixed it)
-I wrote to /etc/inittab
-I create a file named S90dvblast in /etc/init.d/ (This worked but after create this file, I can not connect to MOI via SSH after reboot)

All of these ways, I can not connect to MOI via SSH,FTP,Telnet or WUI again (SSH and Telnet warn me like that "....Connection Refused") and then I reset the MOI everytime.

So, How Can I start these two processes at startup ?
jarmen
 
Posts: 3
Joined: Tue Jul 16, 2013 7:59 pm

Re: MOI Startup Process

Postby gfi » Sat Jul 20, 2013 10:00 pm

jarmen Wrote:Hi All,
I have two dvblast commands to stream two transponders. When I execute them, everythin is ok.
But I want to start automatically on startup.

I tried a lot of ways:
-Crontab is not working (No such file...., but I fixed it)
-I wrote to /etc/inittab
-I create a file named S90dvblast in /etc/init.d/ (This worked but after create this file, I can not connect to MOI via SSH after reboot)

All of these ways, I can not connect to MOI via SSH,FTP,Telnet or WUI again (SSH and Telnet warn me like that "....Connection Refused") and then I reset the MOI everytime.

So, How Can I start these two processes at startup ?


Hi,

How's looking your startup script? Need to be initialized at end of init stripts (S99).

- connect Your MOI via RS232, after initializing busybox, log into system. Use ps, top, for services started viewing.
- control CPU Load in top (again over RS232).
gfi
 
Posts: 114
Joined: Tue Mar 05, 2013 10:55 pm

Re: MOI Startup Process

Postby jarmen » Sun Jul 21, 2013 7:38 pm

Thank you for your reply.

I tried as S98, should I use after 99 such as S100,S102.. ? will it work ?
jarmen
 
Posts: 3
Joined: Tue Jul 16, 2013 7:59 pm

Re: MOI Startup Process

Postby gfi » Mon Jul 22, 2013 2:27 am

jarmen Wrote:Thank you for your reply.

I tried as S98, should I use after 99 such as S100,S102.. ? will it work ?


No, I think last will be ok, but first You need to know CPU load.
Missing informations.
How much channels You're streaming over network, total bitrate and basically SR, FEC, delivery system of TPs.

Try only one channel from one adapter as first.
gfi
 
Posts: 114
Joined: Tue Mar 05, 2013 10:55 pm

Re: MOI Startup Process

Postby jarmen » Mon Jul 22, 2013 5:38 am

I guess problem is not about CPU load or any other hardware resource.

When I start the process in shel manually, eveything is ok.
Then,
I started the same process via an sh file as S98-99-100, it started on startup, it is ok but after this changing I can not connect to MOI via SSH or any other method anymore.

S98 in "/etc/init.d/" is working as I want. But after create this file I can not connect to MOI anymore, and I reset the MOI to connect it.

My question is why I can not connect to MOI after my process start.
jarmen
 
Posts: 3
Joined: Tue Jul 16, 2013 7:59 pm

Re: MOI Startup Process

Postby gfi » Tue Jul 23, 2013 12:31 am

I understand, I know what You mean.

Try to login into MOI over RS232, If You can. Or send log from RS232 communication from start to end.

If You are connected to MOI over RS232, check, what of processes are runing (ssh, vsftpd, httpd etc) or You can control CPU load with top.
gfi
 
Posts: 114
Joined: Tue Mar 05, 2013 10:55 pm

Re: MOI Startup Process

Postby zhangchao » Sat Jan 31, 2015 4:15 pm

hello ,

1. don't wirte command in /etc/inittab.
2. you should only write two command in a shell script and put it in /etc/init.d/ dir.
example:
startdvblast.sh

#!/bin/sh
sleep 15
dvblast -f 10988000 -s 41250000 -v 13 -a 0 -c /opt/dvblast.conf &
dvblast -f 10922000 -s 41250000 -v 13 -a 1 -c /opt/dvblast1.conf &

3. add executable
chmod 777 /etc/init.d/startdvblast.sh

Best regards !
zhangchao
 
Posts: 36
Joined: Thu Jan 17, 2013 4:59 pm

Re: MOI Startup Process

Postby Naomaruta » Sun Nov 01, 2015 4:01 pm

I guess problem is not about CPU load or any other hardware resource.
ไฮโลออนไลน์
Naomaruta
 
Posts: 3
Joined: Sun Aug 23, 2015 6:13 pm


Return to General discussion

Who is online

Users browsing this forum: No registered users and 2 guests