Moderator Control Panel ]

TBS6205 4.19 kernel and i2c errors

It's important to keep your driver and software updated.

TBS6205 4.19 kernel and i2c errors

Postby clanos » Wed May 08, 2019 9:02 pm

Hi,

I'm running Openmediavault (Arrakis 4.1.22 release), which has Debian 9 base (4.19 kernel). I have tvheadend running as a docker on this platform. Unfortuntely the TBS6205 is hitting i2c failures after a very short time on both the opensource and closed source drivers.

Is there an incompatibility with the above kernel and the current set of drivers?

I can backport to 4.14, and will try tonight, amongst providing docker elevated rights and finally running tvheadend natively rather than in a docker.

Many thanks for any advice.
clanos
 
Posts: 8
Joined: Fri Oct 30, 2015 10:47 am

Re: TBS6205 4.19 kernel and i2c errors

Postby clanos » Thu May 09, 2019 12:48 am

The error I'm getting is TBSECP3 driver 0000:06:00.0: i2c xfer timeout.
clanos
 
Posts: 8
Joined: Fri Oct 30, 2015 10:47 am

Re: TBS6205 4.19 kernel and i2c errors

Postby steven » Thu May 09, 2019 11:55 am

Hi

Please have a try like this :
What works for me is bios aspm set to "auto" (whatever that means) and linux pci_aspm disabled by adding "pcie_aspm=off" to the boot command line.
Thanks

Kind Regards

steven
steven
 
Posts: 2134
Joined: Fri Aug 06, 2010 3:23 pm

Re: TBS6205 4.19 kernel and i2c errors

Postby clanos » Thu May 09, 2019 7:33 pm

Thanks Steven I will give this a try tonight.

This has me thinking, perhaps just unticking Low Power Mode for each adapter in TVHeadend will resolve this. I thought I'd tried this but maybe not, and maybe this will stop it trying to control the power state of the tuner, which from your response is the root of the problem.
clanos
 
Posts: 8
Joined: Fri Oct 30, 2015 10:47 am

Re: TBS6205 4.19 kernel and i2c errors

Postby rufus » Wed May 29, 2019 8:34 pm

Hi clanos, how are you doing?

Any progress?
I'm facing issues too using the same setup as yours (Openmediavault 4.19 kernel), and my TBS6281 is identified correctly, but I can't found any services.
The error that I'm getting here when I try to open a channel:

"service instance is bad, reason: No input detected"

When I return to 4.9 kernel, it's work like a charm and all channels works.
I tried both drivers, open (most updated) and the closed, kernels 4.18 and 4.19... Unfortunatelly, same results!

Cheers!
BR
rufus
 
Posts: 5
Joined: Wed Sep 19, 2018 8:55 pm

Re: TBS6205 4.19 kernel and i2c errors

Postby steven » Mon Apr 13, 2020 10:03 am

As we received some feedback when use the new TBS ECP3 card sometimes have i2c error or packet loss issue . then please try like this :

1.Set your BIOS PCI-E slot configuration to Gen2

2.set the GRUB like this
/etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=efi,pci pci=nomsi,noaer"

3.disable the MSI in open source driver :

create text file /etc/modprobe.d/tbsecp3.conf with line:
options tbsecp3 enable_mis=0

after reboot, check with "cat /proc/interrupts" that tbsecp3 whether using MSI.
steven
 
Posts: 2134
Joined: Fri Aug 06, 2010 3:23 pm

Re: TBS6205 4.19 kernel and i2c errors

Postby clanos » Sun Jun 28, 2020 5:51 am

Thanks for the update Steven - appreciated in case I run into this again. I found swapping the PCI-E slot fixed it recently - but this is not always practical.
clanos
 
Posts: 8
Joined: Fri Oct 30, 2015 10:47 am


Return to Driver & Software Update

Who is online

Users browsing this forum: No registered users and 4 guests