Moderator Control Panel ]

Occasional failed recordings

Occasional failed recordings

Postby AdamJacobs » Mon Dec 20, 2021 1:50 am

Hi

I'm using a TBS 6285 tuner card on a server running Ubuntu 20.04. It's recording via MythTV backend (version 31.0).

Most of the time, it works just fine, but every now and then (maybe 5-10% of the time?), a recording fails.

When that happens, I get no recording at all.

This is what my MythTV backend log looks like at the time:

Code: Select All Code
Dec  7 22:18:00 mythserver mythbackend: mythbackend[1355]: I TVRecEvent tv_rec.cpp:1057 (HandleStateChange) TVRec[17]: Changing from None to RecordingOnly
Dec  7 22:18:00 mythserver mythbackend: mythbackend[1355]: I TVRecEvent mythdbcon.cpp:419 (PurgeIdleConnections) New DB connection, total: 18
Dec  7 22:18:00 mythserver mythbackend: mythbackend[1355]: I TVRecEvent tv_rec.cpp:3662 (TuningFrequency) TVRec[17]: TuningFrequency
Dec  7 22:18:00 mythserver mythbackend: mythbackend[1355]: C CoreContext programinfo.cpp:257 (ProgramInfo) ProgramInfo(): Failed to find recorded entry for 0.
Dec  7 22:18:00 mythserver mythbackend: mythbackend[1355]: I TVRecEvent cardutil.cpp:1170 (SetDeliverySystem) CardUtil[17]: Set delivery system: DVB-T2
Dec  7 22:18:00 mythserver mythbackend: mythbackend[1355]: I Scheduler scheduler.cpp:2880 (HandleRecordingStatusChange) Tuning recording: "Amazing Hotels":"Life Beyond the Lobby": channel 20002 on cardid [17], sourceid 2
Dec  7 22:18:02 mythserver mythbackend: mythbackend[1355]: E HttpServer100 programinfo.cpp:2524 (GetPlaybackURL) ProgramInfo(20002_20211207221800.ts): GetPlaybackURL: '20002_20211207221800.ts' should be local, but it can not be found.
Dec  7 22:18:14 mythserver mythbackend: mythbackend[1355]: E TVRecEvent tv_rec.cpp:3967 (TuningSignalCheck) TVRec[17]: TuningSignalCheck: Hit pre-fail timeout
Dec  7 22:18:20 mythserver mythbackend: mythbackend[1355]: W TVRecEvent tv_rec.cpp:3995 (TuningSignalCheck) TVRec[17]: TuningSignalCheck: taking more than 20000 ms to get a lock. marking this recording as 'Failing'.
Dec  7 22:18:20 mythserver mythbackend: mythbackend[1355]: W TVRecEvent tv_rec.cpp:4000 (TuningSignalCheck) TVRec[17]: See 'Tuning timeout' in mythtv-setup for this input
Dec  7 22:18:20 mythserver mythbackend: mythbackend[1355]: I CoreContext scheduler.cpp:706 (UpdateRecStatus) Updating status for "Amazing Hotels":"Life Beyond the Lobby" on cardid [17] (Tuning => Failing)
Dec  7 22:18:20 mythserver mythbackend: mythbackend[1355]: I Scheduler scheduler.cpp:2308 (HandleReschedule) Reschedule requested for CHECK -14 2412 0 UpdateRecStatus2 | Amazing Hotels | Life Beyond the Lobby | Giles Coren and Monica Galetti head to the Andean Cloud Forest of Ecuador to work at Mashpi Lodge, a $10-million modernist hotel. | fp.bbc.co.uk/b/5428bx
Dec  7 22:18:20 mythserver mythbackend: mythbackend[1355]: I Scheduler scheduler.cpp:2425 (HandleReschedule) Scheduled 197 items in 0.1 = 0.04 match + 0.00 check + 0.02 place


When I first saw that I had a tuning timeout, I increased the timeout limit, but as you see above it's already at 20 seconds, which I'm guessing is really as long as it's ever going to take if it's going to not time out at all. Once a recording has started, it continues to record reliably, it's just that sometimes the recording never starts in the first place.

I also get rather frequent errors in my backend log (sometimes a few per hour, sometimes less frequent) that look like this:

Code: Select All Code
Dec 19 12:06:04 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3954 (TuningSignalCheck) TVRec[20]: TuningSignalCheck: SignalMonitor timed out
Dec 19 12:06:05 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3735 (TuningFrequency) TVRec[20]: Failed to set channel to . Reverting to kState_None
Dec 19 12:35:26 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3954 (TuningSignalCheck) TVRec[20]: TuningSignalCheck: SignalMonitor timed out
Dec 19 12:35:26 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3735 (TuningFrequency) TVRec[20]: Failed to set channel to . Reverting to kState_None
Dec 19 12:48:49 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3954 (TuningSignalCheck) TVRec[20]: TuningSignalCheck: SignalMonitor timed out
Dec 19 12:48:50 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3735 (TuningFrequency) TVRec[20]: Failed to set channel to . Reverting to kState_None
Dec 19 12:56:42 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3954 (TuningSignalCheck) TVRec[20]: TuningSignalCheck: SignalMonitor timed out
Dec 19 12:56:43 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3735 (TuningFrequency) TVRec[20]: Failed to set channel to . Reverting to kState_None
Dec 19 12:59:35 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3954 (TuningSignalCheck) TVRec[20]: TuningSignalCheck: SignalMonitor timed out
Dec 19 12:59:35 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3735 (TuningFrequency) TVRec[20]: Failed to set channel to . Reverting to kState_None
Dec 19 15:42:34 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3954 (TuningSignalCheck) TVRec[20]: TuningSignalCheck: SignalMonitor timed out
Dec 19 15:42:34 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3735 (TuningFrequency) TVRec[20]: Failed to set channel to . Reverting to kState_None
Dec 19 17:37:30 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3954 (TuningSignalCheck) TVRec[20]: TuningSignalCheck: SignalMonitor timed out
Dec 19 17:37:30 mythserver mythbackend: mythbackend[2033]: E TVRecEvent tv_rec.cpp:3735 (TuningFrequency) TVRec[20]: Failed to set channel to . Reverting to kState_None


I don't know for sure that those errors are related to the failed recording problem, but as they also mention a timeout, it seems entirely possible that they are related.

Any idea what the problem might be and how I could fix it?

Many thanks for any suggestions.

Adam
AdamJacobs
 
Posts: 2
Joined: Sun Dec 23, 2018 6:54 pm

Re: Occasional failed recordings

Postby smile » Tue Jan 11, 2022 3:11 pm

Hi
Is it four adapters to start recording at the same time?
smile
 
Posts: 135
Joined: Sun Oct 09, 2011 9:51 am


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest